phpMyFAQ Stored Cross-site Scripting at File Attachments
CVE-2024-29179GHSA-hm8r-95g3-5hj9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 3.2.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyfaq/phpmyfaq
- Affected
- >= 3.2.5, <= 3.2.5
- Fixed in
- 3.2.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hm8r-95g3-5hj9 lists affected ranges: Packagist phpmyfaq/phpmyfaq >=3.2.5 <=3.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2024-29179: 0.51% estimated exploitation activity in the next 30 days; percentile 43.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An attacker with admin privileges can upload an attachment containing JS code without extension and the application will render it as HTML which allows for XSS attacks. Details When attachments are uploaded without an extension, the application renders it as HTML by default. Therefore allowing attackers to upload .html files containing javascript code to perform XSS attacks. The direct file path to the uploaded attachment is also easily obtainable as it is made up of substrings of the file's MD5 hashes. PoC 1. Admin users can upload attachments containing XSS payloads in files without extensions to bypass the .html extension check. 2. Since the path of the uploaded file is built entirely on the file’s MD5 hash and the attachment directory, it is possible for an attacker to know the direct path of the uploaded file. E.g file MD5 hash: 38fff51cb7248a06d6142c6bdf846831 URL will be: http://127.0.0.1/phpmyfaq/attachments/38fff/51cb7/248a0/6d6142c6bdf846831 - /attachments - /38fff…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hm8r-95g3-5hj9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-29179 Advisory: phpMyFAQ Stored Cross-site Scripting at File Attachments IDs: CVE-2024-29179, GHSA-hm8r-95g3-5hj9 Record: https://patchnext.com/advisories/cve-2024-29179 (revision 1, source checked 26 Oct 2026, 14:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 3.2.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyfaq/phpmyfaq: affected >= 3.2.5, <= 3.2.5; fixed in 3.2.6 ## Suggested inspection (read-only) - Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyfaq/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hm8r-95g3-5hj9 (GitHub-reviewed advisory GHSA-hm8r-95g3-5hj9 lists affected ranges: Packagist phpmyfaq/phpmyfaq >=3.2.5 <=3.2.5) Commands are suggestions: review each one before running it.
Loading voting…