Skip to content

← Actionable
Medium, CVSS 6.8

CarrierWave content-Type allowlist bypass vulnerability which possibly leads to XSS remained

CVE-2024-29034GHSA-vfmv-jfc5-pjjw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (carrierwave 3.0.7, 2.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems carrierwave

    Affected
    >= 3.0.0, < 3.0.7< 2.2.6
    Fixed in
    2.2.6, 3.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2024-29034: 0.44% estimated exploitation activity in the next 30 days; percentile 38.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The vulnerability CVE-2023-49090 wasn't fully addressed. This vulnerability is caused by the fact that when uploading to object storage, including Amazon S3, it is possible to set a Content-Type value that is interpreted by browsers to be different from what's allowed by contenttypeallowlist, by providing multiple values separated by commas. This bypassed value can be used to cause XSS. Patches Upgrade to 3.0.7 or 2.2.6. Workarounds Use the following monkey patch to let CarrierWave parse the Content-type by using Marcel::MimeType.for. References OWASP - File Upload Cheat Sheet

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vfmv-jfc5-pjjw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-29034

Advisory: CarrierWave content-Type allowlist bypass vulnerability which possibly leads to XSS remained
IDs: CVE-2024-29034, GHSA-vfmv-jfc5-pjjw
Record: https://patchnext.com/advisories/cve-2024-29034 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: carrierwave 3.0.7, 2.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems carrierwave: affected >= 3.0.0, < 3.0.7; < 2.2.6; fixed in 2.2.6, 3.0.7

## Suggested inspection (read-only)
- RubyGems carrierwave: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on carrierwave.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vfmv-jfc5-pjjw (GitHub-reviewed advisory GHSA-vfmv-jfc5-pjjw lists affected ranges: RubyGems carrierwave >=3.0.0 =0 <2.2.6)

Commands are suggestions: review each one before running it.

Loading voting…