GoogleOAuthenticator.hosted_domain incorrectly verifies membership of an Google organization/workspace
CVE-2024-29033GHSA-55m3-44xf-hg4h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (oauthenticator 16.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI oauthenticator
- Affected
- < 16.3.0
- Fixed in
- 16.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-55m3-44xf-hg4h lists affected ranges: PyPI oauthenticator >=0 <16.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-55m3-44xf-hg4h lists affected ranges: PyPI oauthenticator >=0 <16.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2024-29033: 0.59% estimated exploitation activity in the next 30 days; percentile 48.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary and impact [GoogleOAuthenticator.hosteddomain] is used to restrict what Google accounts can be authorized to access a JupyterHub. The restriction is intended to ensure Google accounts are part of one or more Google organizations/workspaces verified to control specified domain(s). The vulnerability is that the actual restriction has been to Google accounts with emails ending with the domain. Such accounts could have been created by anyone which at one time was able to read an email associated with the domain. This was described by Dylan Ayrey (@dxa4481) in this [blog post] from 15th December 2023. Remediation Upgrade to oauthenticator=16.3.0 or restrict who can login another way, such as [allowedusers] or [allowedgooglegroups]. [GoogleOAuthenticator.hosteddomain]: https://oauthenticator.readthedocs.io/en/latest/reference/api/gen/oauthenticator.google.html#oauthenticator.google.GoogleOAuthenticator.hosteddomain [allowedusers]:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-55m3-44xf-hg4h
- Revision 1 · created ·
Published from osv record GHSA-55m3-44xf-hg4h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-29033 Advisory: GoogleOAuthenticator.hosted_domain incorrectly verifies membership of an Google organization/workspace IDs: CVE-2024-29033, GHSA-55m3-44xf-hg4h Record: https://patchnext.com/advisories/cve-2024-29033 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: oauthenticator 16.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI oauthenticator: affected < 16.3.0; fixed in 16.3.0 ## Suggested inspection (read-only) - `python -m pip show oauthenticator`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on oauthenticator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-55m3-44xf-hg4h (OSV record GHSA-55m3-44xf-hg4h lists affected ranges: PyPI oauthenticator >=0 <16.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-55m3-44xf-hg4h (GitHub-reviewed advisory GHSA-55m3-44xf-hg4h lists affected ranges: PyPI oauthenticator >=0 <16.3.0) Commands are suggestions: review each one before running it.
Loading voting…