Skip to content

← Actionable
Medium, CVSS 5.3amended

qiskit_ibm_runtime.RuntimeDecoder can execute arbitrary code

CVE-2024-29032GHSA-x4x5-jv3x-9c7m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (qiskit-ibm-runtime 0.21.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2024-29032: 0.37% estimated exploitation activity in the next 30 days; percentile 31.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary deserializing json data using qiskitibmruntime.RuntimeDecoder can be made to execute arbitrary code given a correctly formatted input string Details RuntimeDecoder is supposed to be able to deserialize JSON strings containing various special types encoded via RuntimeEncoder. However, one can structure a malicious payload to cause the decoder to spawn a subprocess and execute arbitrary code, exploiting this block of code: https://github.com/Qiskit/qiskit-ibm-runtime/blob/16e90f475e78a9d2ae77daa139ef750cfa84ca82/qiskitibmruntime/utils/json.py#L156-L159 PoC (where obviously "echo hi" can be replaced with something much more malicious) notably the following also makes it through the runtime API, with maliciousdata serialized client-side via RuntimeEncoder (and therefore presumably deserialized server-side via RuntimeDecoder?) Impact i don't know if qiskitibmruntime.RuntimeDecoder is used server-side so this may or may not be a serious vulnerability on your end (however it's…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x4x5-jv3x-9c7m

  2. Revision 1 · created ·

    Published from osv record GHSA-x4x5-jv3x-9c7m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-29032

Advisory: `qiskit_ibm_runtime.RuntimeDecoder` can execute arbitrary code
IDs: CVE-2024-29032, GHSA-x4x5-jv3x-9c7m
Record: https://patchnext.com/advisories/cve-2024-29032 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: qiskit-ibm-runtime 0.21.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI qiskit-ibm-runtime: affected >= 0.1.0, < 0.21.2; fixed in 0.21.2

## Suggested inspection (read-only)
- `python -m pip show qiskit-ibm-runtime`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on qiskit-ibm-runtime.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x4x5-jv3x-9c7m (OSV record GHSA-x4x5-jv3x-9c7m lists affected ranges: PyPI qiskit-ibm-runtime >=0.1.0 <0.21.2 (fixed))
- Verified: https://github.com/advisories/GHSA-x4x5-jv3x-9c7m (GitHub-reviewed advisory GHSA-x4x5-jv3x-9c7m lists affected ranges: PyPI qiskit-ibm-runtime >=0.1.0 <0.21.2)

Commands are suggestions: review each one before running it.

Loading voting…