memos vulnerable to Server-Side Request Forgery in /o/get/httpmeta
CVE-2024-29028GHSA-6fcf-g3mp-xj2x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/usememos/memos 0.16.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.16.1
- Fixed in
- 0.16.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6fcf-g3mp-xj2x lists affected ranges: Go github.com/usememos/memos >=0 <0.16.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2024-29028: 1.05% estimated exploitation activity in the next 30 days; percentile 64.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
memos is a privacy-first, lightweight note-taking service. In memos 0.13.2, an SSRF vulnerability exists at the /o/get/httpmeta that allows unauthenticated users to enumerate the internal network and receive limited html values in json form. This vulnerability is fixed in 0.16.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6fcf-g3mp-xj2x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-29028 Advisory: memos vulnerable to Server-Side Request Forgery in /o/get/httpmeta IDs: CVE-2024-29028, GHSA-6fcf-g3mp-xj2x Record: https://patchnext.com/advisories/cve-2024-29028 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/usememos/memos 0.16.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/usememos/memos: affected < 0.16.1; fixed in 0.16.1 ## Suggested inspection (read-only) - Go github.com/usememos/memos: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/usememos/memos. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6fcf-g3mp-xj2x (GitHub-reviewed advisory GHSA-6fcf-g3mp-xj2x lists affected ranges: Go github.com/usememos/memos >=0 <0.16.1) Commands are suggestions: review each one before running it.
Loading voting…