Skip to content

← Actionable
Unrated

Gadget chain in Symfony 1 due to uncontrolled unserialized input in sfNamespacedParameterHolder

CVE-2024-28861GHSA-pv9j-c53q-h433

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (friendsofsymfony1/symfony1 1.5.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2024-28861: 1.55% estimated exploitation activity in the next 30 days; percentile 75.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Symfony 1 has a gadget chain due to dangerous unserialize in sfNamespacedParameterHolder class that would enable an attacker to get remote code execution if a developer unserialize user input in his project. Details This vulnerability present no direct threat but is a vector that will enable remote code execution if a developper deserialize user untrusted data. For example: We will make the assumption this is the case in the rest of this explanation. Symfony 1 provides the class sfNamespacedParameterHolder which implements Serializable interface. In particular, when an instance of this class is deserialized, the normal php behavior is hooked by implementing unserialize() method: Which make an array access on the deserialized data without control on the type of the $data parameter: Thus, an attacker provide any object type in $data to make PHP access to another array/object properties than intended by the developer. In particular, it is possible to abuse the array access which…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pv9j-c53q-h433

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-28861

Advisory: Gadget chain in Symfony 1 due to uncontrolled unserialized input in sfNamespacedParameterHolder
IDs: CVE-2024-28861, GHSA-pv9j-c53q-h433
Record: https://patchnext.com/advisories/cve-2024-28861 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: friendsofsymfony1/symfony1 1.5.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist friendsofsymfony1/symfony1: affected >= 1.1.0, < 1.5.19; fixed in 1.5.19

## Suggested inspection (read-only)
- Packagist friendsofsymfony1/symfony1: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on friendsofsymfony1/symfony1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pv9j-c53q-h433 (GitHub-reviewed advisory GHSA-pv9j-c53q-h433 lists affected ranges: Packagist friendsofsymfony1/symfony1 >=1.1.0 <1.5.19)

Commands are suggestions: review each one before running it.

Loading voting…