tls-listener affected by the slow loris vulnerability with default configuration
CVE-2024-28854GHSA-2qph-qpvm-2qf7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tls-listener 0.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io tls-listener
- Affected
- <= 0.9.1
- Fixed in
- 0.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2qph-qpvm-2qf7 lists affected ranges: crates.io tls-listener >=0 <=0.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-28854: 0.97% estimated exploitation activity in the next 30 days; percentile 62.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary With the default configuration of tls-listener, a malicious user can open 6.4 TcpStreams a second, sending 0 bytes, and can trigger a DoS. Details The default configuration options make any public service using TlsListener::new() vulnerable to a slow-loris DoS attack. PoC Running the HTTP TLS server example: https://github.com/tmccombs/tls-listener/blob/6c57dea2d9beb1577ae4d80f6eaf03aad4ef3857/examples/http.rs, then running the following script will prevent new connections to the server. Impact This is an instance of a slow-loris attack). This impacts any publically accessible service using the default configuration of tls-listener Mitigation Previous versions can mitigate this by passing a large value, such as usize::MAX as the parameter to Builder::maxhandshakes.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2qph-qpvm-2qf7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28854 Advisory: tls-listener affected by the slow loris vulnerability with default configuration IDs: CVE-2024-28854, GHSA-2qph-qpvm-2qf7 Record: https://patchnext.com/advisories/cve-2024-28854 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tls-listener 0.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io tls-listener: affected <= 0.9.1; fixed in 0.10.0 ## Suggested inspection (read-only) - crates.io tls-listener: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tls-listener. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2qph-qpvm-2qf7 (GitHub-reviewed advisory GHSA-2qph-qpvm-2qf7 lists affected ranges: crates.io tls-listener >=0 <=0.9.1) Commands are suggestions: review each one before running it.
Loading voting…