Skip to content

← Actionable
High, CVSS 7.8amended

OpenStack Storlets arbitrary code execution vulnerability

CVE-2024-28717GHSA-rfm2-f94j-qhjp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (storlets 13.0.0.0rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI storlets

    Affected
    < 13.0.0.0rc1
    Fixed in
    13.0.0.0rc1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-28717: 0.89% estimated exploitation activity in the next 30 days; percentile 59.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue in OpenStack Storlets yoga-eom allows a remote attacker to execute arbitrary code via the gateway.py component.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rfm2-f94j-qhjp

  2. Revision 1 · created ·

    Published from osv record GHSA-rfm2-f94j-qhjp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-28717

Advisory: OpenStack Storlets arbitrary code execution vulnerability
IDs: CVE-2024-28717, GHSA-rfm2-f94j-qhjp
Record: https://patchnext.com/advisories/cve-2024-28717 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: storlets 13.0.0.0rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI storlets: affected < 13.0.0.0rc1; fixed in 13.0.0.0rc1

## Suggested inspection (read-only)
- `python -m pip show storlets`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on storlets.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rfm2-f94j-qhjp (OSV record GHSA-rfm2-f94j-qhjp lists affected ranges: PyPI storlets >=0 <13.0.0.0rc1 (fixed))
- Verified: https://github.com/advisories/GHSA-rfm2-f94j-qhjp (GitHub-reviewed advisory GHSA-rfm2-f94j-qhjp lists affected ranges: PyPI storlets >=0 <13.0.0.0rc1)

Commands are suggestions: review each one before running it.

Loading voting…