LimeSurvey Cross Site Scripting vulnerability
CVE-2024-28709GHSA-c7xm-rwqj-pgcj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (limesurvey/limesurvey 6.5.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist limesurvey/limesurvey
- Affected
- < 6.5.12
- Fixed in
- 6.5.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c7xm-rwqj-pgcj lists affected ranges: Packagist limesurvey/limesurvey >=0 <6.5.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-28709: 0.57% estimated exploitation activity in the next 30 days; percentile 47.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross Site Scripting vulnerability in LimeSurvey before 6.5.12+240611 allows a remote attacker to execute arbitrary code via a crafted script to the title and comment fields.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c7xm-rwqj-pgcj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28709 Advisory: LimeSurvey Cross Site Scripting vulnerability IDs: CVE-2024-28709, GHSA-c7xm-rwqj-pgcj Record: https://patchnext.com/advisories/cve-2024-28709 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: limesurvey/limesurvey 6.5.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist limesurvey/limesurvey: affected < 6.5.12; fixed in 6.5.12 ## Suggested inspection (read-only) - Packagist limesurvey/limesurvey: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on limesurvey/limesurvey. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c7xm-rwqj-pgcj (GitHub-reviewed advisory GHSA-c7xm-rwqj-pgcj lists affected ranges: Packagist limesurvey/limesurvey >=0 <6.5.12) Commands are suggestions: review each one before running it.
Loading voting…