Unencrypted traffic between nodes when using IPsec and L7 policies
CVE-2024-28249GHSA-j89h-qrvr-xc36
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.15.2, 1.14.8, 1.13.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.13.13>= 1.14.0, < 1.14.8>= 1.15.0, < 1.15.2
- Fixed in
- 1.13.13, 1.15.2, 1.14.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j89h-qrvr-xc36 lists affected ranges: Go github.com/cilium/cilium >=0 =1.14.0 =1.15.0 <1.15.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2024-28249: 0.27% estimated exploitation activity in the next 30 days; percentile 19.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In Cilium clusters with IPsec enabled and traffic matching Layer 7 policies: - Traffic that should be IPsec-encrypted between a node's Envoy proxy and pods on other nodes is sent unencrypted - Traffic that should be IPsec-encrypted between a node's DNS proxy and pods on other nodes is sent unencrypted Note: For clusters running in native routing mode, IPsec encryption is not applied to connections which are selected by a L7 Egress Network Policy or a DNS Policy. This is a known limitation of Cilium's IPsec encryption which will continue to apply after upgrading to the latest Cilium versions described below. Patches This issue affects: - Cilium v1.15 before v1.15.2 - Cilium v1.14 before v1.14.8 - Cilium v1.13 before v1.13.13 - Cilium v1.4 to v1.12 inclusive This issue has been resolved in: - Cilium v1.15.2 - Cilium v1.14.8 - Cilium v1.13.13 Workarounds There is no workaround to this issue. Acknowledgements The Cilium community has worked together with members of Isovalent to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j89h-qrvr-xc36
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28249 Advisory: Unencrypted traffic between nodes when using IPsec and L7 policies IDs: CVE-2024-28249, GHSA-j89h-qrvr-xc36 Record: https://patchnext.com/advisories/cve-2024-28249 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.15.2, 1.14.8, 1.13.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cilium/cilium: affected < 1.13.13; >= 1.14.0, < 1.14.8; >= 1.15.0, < 1.15.2; fixed in 1.13.13, 1.15.2, 1.14.8 ## Suggested inspection (read-only) - Go github.com/cilium/cilium: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cilium/cilium. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j89h-qrvr-xc36 (GitHub-reviewed advisory GHSA-j89h-qrvr-xc36 lists affected ranges: Go github.com/cilium/cilium >=0 =1.14.0 =1.15.0 <1.15.2) Commands are suggestions: review each one before running it.
Loading voting…