Skip to content

← Actionable
Medium, CVSS 5.5amended

KaTeX missing normalization of the protocol in URLs allows bypassing forbidden protocols

CVE-2024-28246GHSA-3wc5-fcw2-2329

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (katex 0.16.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm katex

    Affected
    >= 0.11.0, < 0.16.10
    Fixed in
    0.16.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2024-28246: 0.41% estimated exploitation activity in the next 30 days; percentile 34.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Code that uses KaTeX's trust option, specifically that provides a function to block-list certain URL protocols, can be fooled by URLs in malicious inputs that use uppercase characters in the protocol. In particular, this can allow for malicious input to generate javascript: links in the output, even if the trust function tries to forbid this protocol via trust: (context) = context.protocol !== 'javascript'. Patches Upgrade to KaTeX v0.16.10 to remove this vulnerability. Workarounds Allow-list instead of block protocols in your trust function. Manually lowercase context.protocol via context.protocol.toLowerCase() before attempting to check for certain protocols. Avoid use of or turn off the trust option. Details KaTeX did not normalize the protocol entry of the context object provided to a user-specified trust-function, so it could be a mix of lowercase and/or uppercase letters. It is generally better to allow-list by protocol, in which case this would normally not be an issue.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3wc5-fcw2-2329

  2. Revision 1 · created ·

    Published from osv record GHSA-3wc5-fcw2-2329

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-28246

Advisory: KaTeX missing normalization of the protocol in URLs allows bypassing forbidden protocols
IDs: CVE-2024-28246, GHSA-3wc5-fcw2-2329
Record: https://patchnext.com/advisories/cve-2024-28246 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: katex 0.16.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm katex: affected >= 0.11.0, < 0.16.10; fixed in 0.16.10

## Suggested inspection (read-only)
- `npm ls katex --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on katex.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3wc5-fcw2-2329 (OSV record GHSA-3wc5-fcw2-2329 lists affected ranges: npm katex >=0.11.0 <0.16.10 (fixed))
- Verified: https://github.com/advisories/GHSA-3wc5-fcw2-2329 (GitHub-reviewed advisory GHSA-3wc5-fcw2-2329 lists affected ranges: npm katex >=0.11.0 <0.16.10)

Commands are suggestions: review each one before running it.

Loading voting…