KaTeX's \includegraphics does not escape filename
CVE-2024-28245GHSA-f98w-7cxr-ff2h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (katex 0.16.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm katex
- Affected
- >= 0.11.0, < 0.16.10
- Fixed in
- 0.16.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f98w-7cxr-ff2h lists affected ranges: npm katex >=0.11.0 <0.16.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f98w-7cxr-ff2h lists affected ranges: npm katex >=0.11.0 <0.16.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2024-28245: 0.41% estimated exploitation activity in the next 30 days; percentile 34.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact KaTeX users who render untrusted mathematical expressions could encounter malicious input using \includegraphics that runs arbitrary JavaScript, or generate invalid HTML. Patches Upgrade to KaTeX v0.16.10 to remove this vulnerability. Workarounds Avoid use of or turn off the trust option, or set it to forbid \includegraphics commands. Forbid inputs containing the substring "\\includegraphics". Sanitize HTML output from KaTeX. Details \includegraphics did not properly quote its filename argument, allowing it to generate invalid or malicious HTML that runs scripts. For more information If you have any questions or comments about this advisory: Open an issue or security advisory in the KaTeX repository Email us at katex-security@mit.edu
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-f98w-7cxr-ff2h
- Revision 1 · created ·
Published from osv record GHSA-f98w-7cxr-ff2h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28245 Advisory: KaTeX's `\includegraphics` does not escape filename IDs: CVE-2024-28245, GHSA-f98w-7cxr-ff2h Record: https://patchnext.com/advisories/cve-2024-28245 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: katex 0.16.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm katex: affected >= 0.11.0, < 0.16.10; fixed in 0.16.10 ## Suggested inspection (read-only) - `npm ls katex --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on katex. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f98w-7cxr-ff2h (OSV record GHSA-f98w-7cxr-ff2h lists affected ranges: npm katex >=0.11.0 <0.16.10 (fixed)) - Verified: https://github.com/advisories/GHSA-f98w-7cxr-ff2h (GitHub-reviewed advisory GHSA-f98w-7cxr-ff2h lists affected ranges: npm katex >=0.11.0 <0.16.10) Commands are suggestions: review each one before running it.
Loading voting…