Skip to content

← Actionable
Medium, CVSS 5.4amended

URL Redirection to Untrusted Site in OAuth2/OpenID in directus

CVE-2024-28239GHSA-fr3w-2p22-6w7p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 10.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    < 10.10.0
    Fixed in
    10.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2024-28239: 0.58% estimated exploitation activity in the next 30 days; percentile 47.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The authentication API has a redirect parameter that can be exploited as an open redirect vulnerability as the user tries to log in via the API URL https://docs.directus.io/reference/authentication.html#login-using-sso-providers /auth/login/google?redirect for example. Details There's a redirect that is done after successful login via the Auth API GET request to directus/auth/login/google?redirect=http://malicious-fishing-site.com, which I think is here: https://github.com/directus/directus/blob/main/api/src/auth/drivers/oauth2.ts#L394. While credentials don't seem to be passed to the attacker site, the user can be phished into clicking a legitimate directus site and be taken to a malicious site made to look like a an error message "Your password needs to be updated" to phish out the current password. PoC Turn on any auth provider in Directus instance. Form a link to directus-instance/auth/login/:providerid?redirect=http://malicious-fishing-site.com, login and get taken to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fr3w-2p22-6w7p

  2. Revision 1 · created ·

    Published from osv record GHSA-fr3w-2p22-6w7p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-28239

Advisory: URL Redirection to Untrusted Site in OAuth2/OpenID in directus
IDs: CVE-2024-28239, GHSA-fr3w-2p22-6w7p
Record: https://patchnext.com/advisories/cve-2024-28239 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 10.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected < 10.10.0; fixed in 10.10.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fr3w-2p22-6w7p (OSV record GHSA-fr3w-2p22-6w7p lists affected ranges: npm directus >=0 <10.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-fr3w-2p22-6w7p (GitHub-reviewed advisory GHSA-fr3w-2p22-6w7p lists affected ranges: npm directus >=0 <10.10.0)

Commands are suggestions: review each one before running it.

Loading voting…