Session Token in URL in directus
CVE-2024-28238GHSA-2ccr-g2rv-h677
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 10.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- < 10.10.0
- Fixed in
- 10.10.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2ccr-g2rv-h677 lists affected ranges: npm directus >=0 <10.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2ccr-g2rv-h677 lists affected ranges: npm directus >=0 <10.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.3 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2024-28238: 0.24% estimated exploitation activity in the next 30 days; percentile 15.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When reaching the /files page, a JWT is passed via GET request. Inclusion of session tokens in URLs poses a security risk as URLs are often logged in various places (e.g., web server logs, browser history). Attackers gaining access to these logs may hijack active user sessions, leading to unauthorized access to sensitive information or actions on behalf of the user. Patches Has the problem been patched? What versions should users upgrade to? Workarounds There's no workaround available. References Are there any links users can visit to find out more?
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2ccr-g2rv-h677
- Revision 1 · created ·
Published from osv record GHSA-2ccr-g2rv-h677
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28238 Advisory: Session Token in URL in directus IDs: CVE-2024-28238, GHSA-2ccr-g2rv-h677 Record: https://patchnext.com/advisories/cve-2024-28238 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 10.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected < 10.10.0; fixed in 10.10.0 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2ccr-g2rv-h677 (OSV record GHSA-2ccr-g2rv-h677 lists affected ranges: npm directus >=0 <10.10.0 (fixed)) - Verified: https://github.com/advisories/GHSA-2ccr-g2rv-h677 (GitHub-reviewed advisory GHSA-2ccr-g2rv-h677 lists affected ranges: npm directus >=0 <10.10.0) Commands are suggestions: review each one before running it.
Loading voting…