XSS via the "Snapshot Test" feature in Classic Webcam plugin settings
CVE-2024-28237GHSA-x7mf-wrh9-r76c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 1.10.0rc3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI octoprint
- Affected
- <= 1.9.3
- Fixed in
- 1.10.0rc3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x7mf-wrh9-r76c lists affected ranges: PyPI octoprint >=0 <1.10.0rc3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x7mf-wrh9-r76c lists affected ranges: PyPI octoprint >=0 <=1.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.0 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2024-28237: 0.44% estimated exploitation activity in the next 30 days; percentile 38.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact OctoPrint versions up until and including 1.9.3 contain a vulnerability that allows malicious admins to configure or talk a victim with administrator rights into configuring a webcam snapshot URL which when tested through the "Test" button included in the web interface will execute JavaScript code in the victims browser when attempting to render the snapshot image. An attacker who successfully talked a victim with admin rights into performing a snapshot test with such a crafted URL could use this to retrieve or modify sensitive configuration settings, interrupt prints or otherwise interact with the OctoPrint instance in a malicious way. Patches The vulnerability will be patched in version 1.10.0. Workaround OctoPrint administrators are strongly advised to thoroughly vet who has admin access to their installation and what settings they modify based on instructions by strangers. PoC Below are the steps to reproduce the vulnerability: 1. Create a URL that responds with a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x7mf-wrh9-r76c
- Revision 1 · created ·
Published from osv record GHSA-x7mf-wrh9-r76c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28237 Advisory: XSS via the "Snapshot Test" feature in Classic Webcam plugin settings IDs: CVE-2024-28237, GHSA-x7mf-wrh9-r76c Record: https://patchnext.com/advisories/cve-2024-28237 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: octoprint 1.10.0rc3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI octoprint: affected <= 1.9.3; fixed in 1.10.0rc3 ## Suggested inspection (read-only) - `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on octoprint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x7mf-wrh9-r76c (OSV record GHSA-x7mf-wrh9-r76c lists affected ranges: PyPI octoprint >=0 <1.10.0rc3 (fixed)) - Verified: https://github.com/advisories/GHSA-x7mf-wrh9-r76c (GitHub-reviewed advisory GHSA-x7mf-wrh9-r76c lists affected ranges: PyPI octoprint >=0 <=1.9.3) Commands are suggestions: review each one before running it.
Loading voting…