Contao: Insufficient BBCode sanitizer
CVE-2024-28234GHSA-j55w-hjpj-825g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/comments-bundle 5.3.4, 4.13.40), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist contao/comments-bundle
- Affected
- >= 2.0.0, < 4.13.40>= 5.0.0-RC1, < 5.3.4
- Fixed in
- 4.13.40, 5.3.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j55w-hjpj-825g lists affected ranges: Packagist contao/comments-bundle >=2.0.0 =5.0.0-RC1 <5.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2024-28234: 0.57% estimated exploitation activity in the next 30 days; percentile 47.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If BBCode is enabled for comments, users can inject CSS styles. Patches Update to Contao 4.13.40 or 5.3.4. Workarounds Disable BBCode for comments. References https://contao.org/en/security-advisories/insufficient-bbcode-sanitization For more information If you have any questions or comments about this advisory, open an issue in contao/contao.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j55w-hjpj-825g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28234 Advisory: Contao: Insufficient BBCode sanitizer IDs: CVE-2024-28234, GHSA-j55w-hjpj-825g Record: https://patchnext.com/advisories/cve-2024-28234 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: contao/comments-bundle 5.3.4, 4.13.40. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist contao/comments-bundle: affected >= 2.0.0, < 4.13.40; >= 5.0.0-RC1, < 5.3.4; fixed in 4.13.40, 5.3.4 ## Suggested inspection (read-only) - Packagist contao/comments-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on contao/comments-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j55w-hjpj-825g (GitHub-reviewed advisory GHSA-j55w-hjpj-825g lists affected ranges: Packagist contao/comments-bundle >=2.0.0 =5.0.0-RC1 <5.3.4) Commands are suggestions: review each one before running it.
Loading voting…