Cross site scripting (XSS) in JupyterHub via Self-XSS leveraged by Cookie Tossing
CVE-2024-28233GHSA-7r3h-4ph8-w38g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterhub 4.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyterhub
- Affected
- < 4.1.0
- Fixed in
- 4.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7r3h-4ph8-w38g lists affected ranges: PyPI jupyterhub >=0 <4.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7r3h-4ph8-w38g lists affected ranges: PyPI jupyterhub >=0 <4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2024-28233: 0.33% estimated exploitation activity in the next 30 days; percentile 26.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Affected configurations: - Single-origin JupyterHub deployments - JupyterHub deployments with user-controlled applications running on subdomains or peer subdomains of either the Hub or a single-user server. By tricking a user into visiting a malicious subdomain, the attacker can achieve an XSS directly affecting the former's session. More precisely, in the context of JupyterHub, this XSS could achieve the following: - Full access to JupyterHub API and user's single-user server, e.g. - Create and exfiltrate an API Token - Exfiltrate all files hosted on the user's single-user server: notebooks, images, etc. - Install malicious extensions. They can be used as a backdoor to silently regain access to victim's session anytime. Patches To prevent cookie-tossing: - Upgrade to JupyterHub 4.1 (both hub and user environment) - enable per-user domains via c.JupyterHub.subdomainhost = "https://mydomain.example.org" - set c.JupyterHub.cookiehostprefixenabled = True to enable domain-locked…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7r3h-4ph8-w38g
- Revision 1 · created ·
Published from osv record GHSA-7r3h-4ph8-w38g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28233 Advisory: Cross site scripting (XSS) in JupyterHub via Self-XSS leveraged by Cookie Tossing IDs: CVE-2024-28233, GHSA-7r3h-4ph8-w38g Record: https://patchnext.com/advisories/cve-2024-28233 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyterhub 4.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyterhub: affected < 4.1.0; fixed in 4.1.0 ## Suggested inspection (read-only) - `python -m pip show jupyterhub`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyterhub. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7r3h-4ph8-w38g (OSV record GHSA-7r3h-4ph8-w38g lists affected ranges: PyPI jupyterhub >=0 <4.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7r3h-4ph8-w38g (GitHub-reviewed advisory GHSA-7r3h-4ph8-w38g lists affected ranges: PyPI jupyterhub >=0 <4.1.0) Commands are suggestions: review each one before running it.
Loading voting…