Skip to content

← Actionable
Low, CVSS 3.1

Contao: Unencoded insert tags in the frontend

CVE-2024-28191GHSA-747v-52c4-8vj8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/core-bundle 5.3.4, 4.13.40), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist contao/core-bundle

    Affected
    >= 4.0.0, < 4.13.40>= 5.0.0-RC1, < 5.3.4
    Fixed in
    4.13.40, 5.3.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-28191: 0.50% estimated exploitation activity in the next 30 days; percentile 42.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact It is possible to inject insert tags via the form generator if the submitted form data is output on the page in a specific way. Patches Update to Contao 4.13.40 or 5.3.4. Workarounds Do not output the submitted form data on the website. References https://contao.org/en/security-advisories/insert-tag-injection-via-the-form-generator For more information If you have any questions or comments about this advisory, open an issue in contao/contao.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-747v-52c4-8vj8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-28191

Advisory: Contao: Unencoded insert tags in the frontend
IDs: CVE-2024-28191, GHSA-747v-52c4-8vj8
Record: https://patchnext.com/advisories/cve-2024-28191 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: contao/core-bundle 5.3.4, 4.13.40. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist contao/core-bundle: affected >= 4.0.0, < 4.13.40; >= 5.0.0-RC1, < 5.3.4; fixed in 4.13.40, 5.3.4

## Suggested inspection (read-only)
- Packagist contao/core-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on contao/core-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-747v-52c4-8vj8 (GitHub-reviewed advisory GHSA-747v-52c4-8vj8 lists affected ranges: Packagist contao/core-bundle >=4.0.0 =5.0.0-RC1 <5.3.4)

Commands are suggestions: review each one before running it.

Loading voting…