jupyter-scheduler's endpoint is missing authentication
CVE-2024-28188GHSA-v9g2-g7j4-4jxc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-scheduler 2.5.2, 1.8.2, 1.2.1, 1.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-scheduler
- Affected
- >= 1.0.0, < 1.1.6>= 1.2.0, <= 1.2.0>= 1.3.0, < 1.8.2>= 2.0.0, < 2.5.2
- Fixed in
- 2.5.2, 1.1.6, 1.8.2, 1.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v9g2-g7j4-4jxc lists affected ranges: PyPI jupyter-scheduler >=1.0.0 =1.2.0 =1.3.0 =2.0.0 <2.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v9g2-g7j4-4jxc lists affected ranges: PyPI jupyter-scheduler >=1.0.0 =1.2.0 =1.3.0 =2.0.0 <2.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2024-28188: 0.33% estimated exploitation activity in the next 30 days; percentile 26.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact jupyterscheduler is missing an authentication check in Jupyter Server on an API endpoint (GET /scheduler/runtimeenvironments) which lists the names of the Conda environments on the server. In affected versions, jupyterscheduler allows an unauthenticated user to obtain the list of Conda environment names on the server. This reveals any information that may be present in a Conda environment name. This issue does not allow an unauthenticated third party to read, modify, or enter the Conda environments present on the server where jupyterscheduler is running. This issue only reveals the list of Conda environment names. Impacted versions: =1.0.0,<=1.1.5 ; ==1.2.0 ; =1.3.0,<=1.8.1 ; =2.0.0,<=2.5.1 Patches jupyter-scheduler==1.1.6 jupyter-scheduler==1.2.1 jupyter-scheduler==1.8.2 jupyter-scheduler==2.5.2 Workarounds Server operators who are unable to upgrade can disable the jupyter-scheduler extension with: References If you have any questions or comments about this advisory we ask…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v9g2-g7j4-4jxc
- Revision 1 · created ·
Published from osv record GHSA-v9g2-g7j4-4jxc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28188 Advisory: jupyter-scheduler's endpoint is missing authentication IDs: CVE-2024-28188, GHSA-v9g2-g7j4-4jxc Record: https://patchnext.com/advisories/cve-2024-28188 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-scheduler 2.5.2, 1.8.2, 1.2.1, 1.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-scheduler: affected >= 1.0.0, < 1.1.6; >= 1.2.0, <= 1.2.0; >= 1.3.0, < 1.8.2; >= 2.0.0, < 2.5.2; fixed in 2.5.2, 1.1.6, 1.8.2, 1.2.1 ## Suggested inspection (read-only) - `python -m pip show jupyter-scheduler`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-scheduler. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v9g2-g7j4-4jxc (OSV record GHSA-v9g2-g7j4-4jxc lists affected ranges: PyPI jupyter-scheduler >=1.0.0 =1.2.0 =1.3.0 =2.0.0 <2.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-v9g2-g7j4-4jxc (GitHub-reviewed advisory GHSA-v9g2-g7j4-4jxc lists affected ranges: PyPI jupyter-scheduler >=1.0.0 =1.2.0 =1.3.0 =2.0.0 <2.5.2) Commands are suggestions: review each one before running it.
Loading voting…