Skip to content

← Actionable
High, CVSS 8.1amended

TurboBoost Commands vulnerable to arbitrary method invocation

CVE-2024-28181GHSA-mp76-7w5v-pr75

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (turbo_boost-commands 0.2.2, 0.1.3; @turbo-boost/commands 0.2.2, 0.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-28181: 0.80% estimated exploitation activity in the next 30 days; percentile 56.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact TurboBoost Commands has existing protections in place to guarantee that only public methods on Command classes can be invoked; however, the existing checks aren't as robust as they should be. It's possible for a sophisticated attacker to invoke more methods than should be permitted depending on the the strictness of authorization checks that individual applications enforce. Being able to call some of these methods can have security implications. Details Commands verify that the class must be a Command and that the method requested is defined as a public method; however, this isn't robust enough to guard against all unwanted code execution. The library should more strictly enforce which methods are considered safe before allowing them to be executed. Patches Patched in the following versions. - 0.1.3 - NPM Package - Ruby GEM - 0.2.2 - NPM Package - Ruby GEM Workarounds You can add this guard to mitigate the issue if running an unpatched version of the library.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mp76-7w5v-pr75

  2. Revision 1 · created ·

    Published from osv record GHSA-mp76-7w5v-pr75

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-28181

Advisory: TurboBoost Commands vulnerable to arbitrary method invocation
IDs: CVE-2024-28181, GHSA-mp76-7w5v-pr75
Record: https://patchnext.com/advisories/cve-2024-28181 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: turbo_boost-commands 0.2.2, 0.1.3; @turbo-boost/commands 0.2.2, 0.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems turbo_boost-commands: affected < 0.1.3; >= 0.2.0, < 0.2.2; fixed in 0.1.3, 0.2.2
- npm @turbo-boost/commands: affected < 0.1.3; >= 0.2.0, < 0.2.2; fixed in 0.1.3, 0.2.2

## Suggested inspection (read-only)
- RubyGems turbo_boost-commands: check the installed version with your package manager.
- `npm ls @turbo-boost/commands --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on turbo_boost-commands, @turbo-boost/commands.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mp76-7w5v-pr75 (OSV record GHSA-mp76-7w5v-pr75 lists affected ranges: RubyGems turbo_boost-commands >=0 =0.2.0 =0 =0.2.0 <0.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-mp76-7w5v-pr75 (GitHub-reviewed advisory GHSA-mp76-7w5v-pr75 lists affected ranges: RubyGems turbo_boost-commands >=0 =0.2.0 =0 =0.2.0 <0.2.2)

Commands are suggestions: review each one before running it.

Loading voting…