Jupyter Server Proxy's Websocket Proxying does not require authentication
CVE-2024-28179GHSA-w3vc-fx9p-wp4v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server-proxy 4.1.1, 3.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-server-proxy
- Affected
- >= 4.0.0, < 4.1.1< 3.2.3
- Fixed in
- 3.2.3, 4.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w3vc-fx9p-wp4v lists affected ranges: PyPI jupyter-server-proxy >=4.0.0 =0 <3.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w3vc-fx9p-wp4v lists affected ranges: PyPI jupyter-server-proxy >=4.0.0 =0 <3.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-28179: 1.03% estimated exploitation activity in the next 30 days; percentile 63.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary jupyter-server-proxy is used to expose ports local to a Jupyter server listening to web traffic to the Jupyter server's authenticated users by proxying web requests and websockets. Dependent packages (partial list) also use jupyter-server-proxy to expose other popular interactive applications (such as RStudio, Linux Desktop via VNC, Code Server, Panel, etc) along with the Jupyter server. This feature is commonly used in hosted environments (such as a JupyterHub) to expose non-Jupyter interactive frontends or APIs to the user. jupyter-server-proxy did not check user authentication appropriately when proxying websockets, allowing unauthenticated access to anyone who had network access to the Jupyter server endpoint. Impact This vulnerability can allow unauthenticated remote access to any websocket endpoint set up to be accessible via jupyter-server-proxy. In many cases (such as when exposing RStudio via jupyter-rsession-proxy or a remote Linux Desktop / VNC via…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w3vc-fx9p-wp4v
- Revision 1 · created ·
Published from osv record GHSA-w3vc-fx9p-wp4v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28179 Advisory: Jupyter Server Proxy's Websocket Proxying does not require authentication IDs: CVE-2024-28179, GHSA-w3vc-fx9p-wp4v Record: https://patchnext.com/advisories/cve-2024-28179 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-server-proxy 4.1.1, 3.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-server-proxy: affected >= 4.0.0, < 4.1.1; < 3.2.3; fixed in 3.2.3, 4.1.1 ## Suggested inspection (read-only) - `python -m pip show jupyter-server-proxy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-server-proxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w3vc-fx9p-wp4v (OSV record GHSA-w3vc-fx9p-wp4v lists affected ranges: PyPI jupyter-server-proxy >=4.0.0 =0 <3.2.3 (fixed)) - Verified: https://github.com/advisories/GHSA-w3vc-fx9p-wp4v (GitHub-reviewed advisory GHSA-w3vc-fx9p-wp4v lists affected ranges: PyPI jupyter-server-proxy >=4.0.0 =0 <3.2.3) Commands are suggestions: review each one before running it.
Loading voting…