Jenkins AppSpider Plugin missing permission checks
CVE-2024-28155GHSA-xxv9-w5hm-328j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.rapid7:jenkinsci-appspider-plugin 1.0.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.rapid7:jenkinsci-appspider-plugin
- Affected
- < 1.0.17
- Fixed in
- 1.0.17
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xxv9-w5hm-328j lists affected ranges: Maven com.rapid7:jenkinsci-appspider-plugin >=0 <1.0.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2024-28155: 0.45% estimated exploitation activity in the next 30 days; percentile 39.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins AppSpider Plugin 1.0.16 and earlier does not perform permission checks in several HTTP endpoints, allowing attackers with Overall/Read permission to obtain information about available scan config names, engine group names, and client names.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xxv9-w5hm-328j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28155 Advisory: Jenkins AppSpider Plugin missing permission checks IDs: CVE-2024-28155, GHSA-xxv9-w5hm-328j Record: https://patchnext.com/advisories/cve-2024-28155 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.rapid7:jenkinsci-appspider-plugin 1.0.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.rapid7:jenkinsci-appspider-plugin: affected < 1.0.17; fixed in 1.0.17 ## Suggested inspection (read-only) - Maven com.rapid7:jenkinsci-appspider-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.rapid7:jenkinsci-appspider-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xxv9-w5hm-328j (GitHub-reviewed advisory GHSA-xxv9-w5hm-328j lists affected ranges: Maven com.rapid7:jenkinsci-appspider-plugin >=0 <1.0.17) Commands are suggestions: review each one before running it.
Loading voting…