Skip to content

← Actionable
High, CVSS 7.3

Wasmi Out-of-bounds Write for host to Wasm calls with more than 128 Parameters

CVE-2024-28123GHSA-75jp-vq8x-h4cq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wasmi 0.31.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io wasmi

    Affected
    >= 0.15.0, <= 0.31.0
    Fixed in
    0.31.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2024-28123: 0.80% estimated exploitation activity in the next 30 days; percentile 56.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In the WASMI Interpreter, an Out-of-bounds Buffer Write will arise arise if the host calls or resumes a Wasm function with more parameters than the default limit (128), as it will surpass the stack value. This doesn’t affect calls from Wasm to Wasm, only from host to Wasm. Impact After conducting an analysis of the dependent Polkadot systems of wasmi: Pallet Contracts, Parity Signer, and Smoldot, we have found that none on those systems have been affected by the issue as they are calling host to Wasm function with a small limited amount of parameters always. Mitigations If you are using wasmi betwen version 0.15.0 and 0.31.0, please update it to the 0.31.1 patch release that we just published. Workarounds Ensure no more than 128 parameters can be pass in a call from the host to a Wasm function. References Patch PR: <PR Special thanks Special thanks to Stellar Development Foundation for reporting this security vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-75jp-vq8x-h4cq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-28123

Advisory: Wasmi Out-of-bounds Write for host to Wasm calls with more than 128 Parameters
IDs: CVE-2024-28123, GHSA-75jp-vq8x-h4cq
Record: https://patchnext.com/advisories/cve-2024-28123 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wasmi 0.31.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io wasmi: affected >= 0.15.0, <= 0.31.0; fixed in 0.31.1

## Suggested inspection (read-only)
- crates.io wasmi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wasmi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-75jp-vq8x-h4cq (GitHub-reviewed advisory GHSA-75jp-vq8x-h4cq lists affected ranges: crates.io wasmi >=0.15.0 <=0.31.0)

Commands are suggestions: review each one before running it.

Loading voting…