JWX vulnerable to a denial of service attack using compressed JWE message
CVE-2024-28122GHSA-hj3v-m684-v259
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/lestrrat-go/jwx/v2 2.0.21; github.com/lestrrat-go/jwx 1.2.29), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/lestrrat-go/jwx/v2
- Affected
- < 2.0.21
- Fixed in
- 2.0.21
- Affected
- < 1.2.29
- Fixed in
- 1.2.29
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hj3v-m684-v259 lists affected ranges: Go github.com/lestrrat-go/jwx/v2 >=0 =0 <1.2.29
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H
- EPSS
- CVE-2024-28122: 0.57% estimated exploitation activity in the next 30 days; percentile 47.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary This vulnerability allows an attacker with a trusted public key to cause a Denial-of-Service (DoS) condition by crafting a malicious JSON Web Encryption (JWE) token with an exceptionally high compression ratio. When this token is processed by the recipient, it results in significant memory allocation and processing time during decompression. Details The attacker needs to obtain a valid public key to compress the payload. It needs to be valid so that the recipient can use to successfully decompress the payload. Furthermore in context JWT processing in the v2 versions, the recipient must explicitly allow JWE handling . The attacker then crafts a message with high compression ratio, e.g. a payload with very high frequency of repeating patterns that can decompress to a much larger size. If the payload is large enough, recipient who is decompressing the data will have to allocate a large amount of memory, which then can lead to a denial of service. The original report includes a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hj3v-m684-v259
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28122 Advisory: JWX vulnerable to a denial of service attack using compressed JWE message IDs: CVE-2024-28122, GHSA-hj3v-m684-v259 Record: https://patchnext.com/advisories/cve-2024-28122 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/lestrrat-go/jwx/v2 2.0.21; github.com/lestrrat-go/jwx 1.2.29. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/lestrrat-go/jwx/v2: affected < 2.0.21; fixed in 2.0.21 - Go github.com/lestrrat-go/jwx: affected < 1.2.29; fixed in 1.2.29 ## Suggested inspection (read-only) - Go github.com/lestrrat-go/jwx/v2: check the installed version with your package manager. - Go github.com/lestrrat-go/jwx: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/lestrrat-go/jwx/v2, github.com/lestrrat-go/jwx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hj3v-m684-v259 (GitHub-reviewed advisory GHSA-hj3v-m684-v259 lists affected ranges: Go github.com/lestrrat-go/jwx/v2 >=0 =0 <1.2.29) Commands are suggestions: review each one before running it.
Loading voting…