Skip to content

← Actionable
High, CVSS 8.8amended

StimulusReflex arbitrary method call

CVE-2024-28121GHSA-f78j-4w3g-4q65

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (stimulus_reflex 3.5.0.rc4, 3.4.2; stimulus_reflex 3.5.0-rc4, 3.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems stimulus_reflex

    Affected
    >= 3.5.0.pre0, < 3.5.0.rc4< 3.4.2
    Fixed in
    3.5.0.rc4, 3.4.2
  • npm stimulus_reflex

    Affected
    < 3.4.2>= 3.5.0-pre0, < 3.5.0-rc4
    Fixed in
    3.5.0-rc4, 3.4.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-28121: 1.55% estimated exploitation activity in the next 30 days; percentile 75.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary More methods than expected can be called on reflex instances. Being able to call some of them has security implications. Details To invoke a reflex a websocket message of the following shape is sent: The server will proceed to instantiate reflex using the provided classname as long as it extends StimulusReflex::Reflex. It then attempts to call methodname on the instance with the provided arguments ref: This is problematic as reflex.method(methodname) can be more methods than those explicitly specified by the developer in their reflex class. A good example is the instancevariableset method. <details <summaryRead more</summary Let's imagine a reflex that uses @user as a trusted variable in an afterreflex callback. This variable can be overwritten using the following message: Here are other interesting methods that were found to be available for the ChatReflex sample reflex - remotebyebug: bind a debugging server - pry: drop the process in a REPL session All in all, only…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f78j-4w3g-4q65

  2. Revision 1 · created ·

    Published from osv record GHSA-f78j-4w3g-4q65

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-28121

Advisory: StimulusReflex arbitrary method call
IDs: CVE-2024-28121, GHSA-f78j-4w3g-4q65
Record: https://patchnext.com/advisories/cve-2024-28121 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: stimulus_reflex 3.5.0.rc4, 3.4.2; stimulus_reflex 3.5.0-rc4, 3.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems stimulus_reflex: affected >= 3.5.0.pre0, < 3.5.0.rc4; < 3.4.2; fixed in 3.5.0.rc4, 3.4.2
- npm stimulus_reflex: affected < 3.4.2; >= 3.5.0-pre0, < 3.5.0-rc4; fixed in 3.5.0-rc4, 3.4.2

## Suggested inspection (read-only)
- RubyGems stimulus_reflex: check the installed version with your package manager.
- `npm ls stimulus_reflex --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on stimulus_reflex.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f78j-4w3g-4q65 (OSV record GHSA-f78j-4w3g-4q65 lists affected ranges: RubyGems stimulus_reflex >=3.5.0.pre0 =0 =3.5.0-pre0 =0 <3.4.2 (fixed))
- Verified: https://github.com/advisories/GHSA-f78j-4w3g-4q65 (GitHub-reviewed advisory GHSA-f78j-4w3g-4q65 lists affected ranges: RubyGems stimulus_reflex >=3.5.0.pre0 =0 =0 =3.5.0-pre0 <3.5.0-rc4)

Commands are suggestions: review each one before running it.

Loading voting…