phpMyFAQ Stored HTML Injection at contentLink
CVE-2024-28108GHSA-48vw-jpf8-hwqh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 3.2.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyfaq/phpmyfaq
- Affected
- >= 3.2.5, <= 3.2.5
- Fixed in
- 3.2.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-48vw-jpf8-hwqh lists affected ranges: Packagist phpmyfaq/phpmyfaq >=3.2.5 <=3.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2024-28108: 0.54% estimated exploitation activity in the next 30 days; percentile 45.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Due to insufficient validation on the contentLink parameter, it is possible for unauthenticated users to inject HTML code to the page which might affect other users. Also, requires that adding new FAQs is allowed for guests and that the admin doesn't check the content of a newly added FAQ. PoC 1. Browse to ../phpmyfaq/index.php?action=add&cat=0 , enter https://test.com?p=<h1HTMLINJECTION</h1 for the contentLink parameter. 2. Verify the HTML injection by viewing the FAQ itself, “All categories” → “CategoryName” → ”QuestionName”. Impact Attackers can manipulate the appearance and functionality of web pages by injecting malicious HTML code. This can lead to various undesirable outcomes, such as defacing the website, redirecting users to malicious sites, or altering the content to deceive users. Additionally, unauthenticated HTML injection can compromise user privacy by displaying sensitive information or misleading content. It undermines the integrity of the application and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-48vw-jpf8-hwqh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28108 Advisory: phpMyFAQ Stored HTML Injection at contentLink IDs: CVE-2024-28108, GHSA-48vw-jpf8-hwqh Record: https://patchnext.com/advisories/cve-2024-28108 (revision 1, source checked 26 Oct 2026, 14:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 3.2.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyfaq/phpmyfaq: affected >= 3.2.5, <= 3.2.5; fixed in 3.2.6 ## Suggested inspection (read-only) - Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyfaq/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-48vw-jpf8-hwqh (GitHub-reviewed advisory GHSA-48vw-jpf8-hwqh lists affected ranges: Packagist phpmyfaq/phpmyfaq >=3.2.5 <=3.2.5) Commands are suggestions: review each one before running it.
Loading voting…