Skip to content

← Actionable
Medium, CVSS 4.3

phpMyFAQ Stored Cross-site Scripting at FAQ News Content

CVE-2024-28106GHSA-6p68-36m6-392r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 3.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2024-28106: 0.54% estimated exploitation activity in the next 30 days; percentile 45.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary By manipulating the news parameter in a POST request, an attacker can inject malicious JavaScript code. Upon browsing to the compromised news page, the XSS payload triggers. PoC 1. Edit a FAQ news, intercept the request and modify the news parameter in the POST body with the following payload: %3cscript%3ealert('xssContent')%3c%2fscript%3e 2. Browse to the particular news page and the XSS should pop up. Impact This allows an attacker to execute arbitrary client side JavaScript within the context of another user's phpMyFAQ session

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6p68-36m6-392r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-28106

Advisory: phpMyFAQ Stored Cross-site Scripting at FAQ News Content
IDs: CVE-2024-28106, GHSA-6p68-36m6-392r
Record: https://patchnext.com/advisories/cve-2024-28106 (revision 1, source checked 26 Oct 2026, 14:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 3.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyfaq/phpmyfaq: affected >= 3.2.5, <= 3.2.5; fixed in 3.2.6

## Suggested inspection (read-only)
- Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyfaq/phpmyfaq.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6p68-36m6-392r (GitHub-reviewed advisory GHSA-6p68-36m6-392r lists affected ranges: Packagist phpmyfaq/phpmyfaq >=3.2.5 <=3.2.5)

Commands are suggestions: review each one before running it.

Loading voting…