Skip to content

← Actionable
Medium, CVSS 5.4

Missing security headers in Action Pack on non-HTML responses

CVE-2024-28103GHSA-fwhr-88qx-h9g7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionpack 7.2.0.beta2, 7.1.3.4, 7.0.8.4, 6.1.7.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems actionpack

    Affected
    >= 6.1.0, < 6.1.7.8>= 7.0.0, < 7.0.8.4>= 7.1.0, < 7.1.3.4>= 7.2.0.beta1, <= 7.2.0.beta1
    Fixed in
    7.2.0.beta2, 7.1.3.4, 7.0.8.4, 6.1.7.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2024-28103: 0.66% estimated exploitation activity in the next 30 days; percentile 51.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Permissions-Policy is Only Served on HTML Content-Type The application configurable Permissions-Policy is only served on responses with an HTML related Content-Type. This has been assigned the CVE identifier CVE-2024-28103. Versions Affected: = 6.1.0 Not affected: < 6.1.0 Fixed Versions: 6.1.7.8, 7.0.8.4, and 7.1.3.4 Impact ------ Responses with a non-HTML Content-Type are not serving the configured Permissions-Policy. There are certain non-HTML Content-Types that would benefit from having the Permissions-Policy enforced. Releases -------- The fixed releases are available at the normal locations. Workarounds ----------- N/A Patches ------- To aid users who aren't able to upgrade immediately we have provided patches for the supported release series in accordance with our maintenance policy regarding security issues. They are in git-am format and consist of a single changeset. 6-1-include-permissions-policy-header-on-non-html.patch - Patch for 6.1 series…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fwhr-88qx-h9g7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-28103

Advisory: Missing security headers in Action Pack on non-HTML responses
IDs: CVE-2024-28103, GHSA-fwhr-88qx-h9g7
Record: https://patchnext.com/advisories/cve-2024-28103 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: actionpack 7.2.0.beta2, 7.1.3.4, 7.0.8.4, 6.1.7.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems actionpack: affected >= 6.1.0, < 6.1.7.8; >= 7.0.0, < 7.0.8.4; >= 7.1.0, < 7.1.3.4; >= 7.2.0.beta1, <= 7.2.0.beta1; fixed in 7.2.0.beta2, 7.1.3.4, 7.0.8.4, 6.1.7.8

## Suggested inspection (read-only)
- RubyGems actionpack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on actionpack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fwhr-88qx-h9g7 (GitHub-reviewed advisory GHSA-fwhr-88qx-h9g7 lists affected ranges: RubyGems actionpack >=6.1.0 =7.0.0 =7.1.0 =7.2.0.beta1 <=7.2.0.beta1)

Commands are suggestions: review each one before running it.

Loading voting…