LangChain directory traversal vulnerability
CVE-2024-28088GHSA-h59x-p739-982c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain 0.0.339; langchain-core 0.1.30), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langchain
- Affected
- < 0.0.339
- Fixed in
- 0.0.339
PyPI langchain-core
- Affected
- < 0.1.30
- Fixed in
- 0.1.30
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h59x-p739-982c lists affected ranges: PyPI langchain >=0 =0 <0.1.30 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h59x-p739-982c lists affected ranges: PyPI langchain >=0 =0 <0.1.30
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2024-28088: 1.74% estimated exploitation activity in the next 30 days; percentile 77.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
LangChain through 0.1.10 allows ../ directory traversal by an actor who is able to control the final part of the path parameter in a loadchain call. This bypasses the intended behavior of loading configurations only from the hwchase17/langchain-hub GitHub repository. The outcome can be disclosure of an API key for a large language model online service, or remote code execution.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h59x-p739-982c
- Revision 1 · created ·
Published from osv record GHSA-h59x-p739-982c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28088 Advisory: LangChain directory traversal vulnerability IDs: CVE-2024-28088, GHSA-h59x-p739-982c Record: https://patchnext.com/advisories/cve-2024-28088 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langchain 0.0.339; langchain-core 0.1.30. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langchain: affected < 0.0.339; fixed in 0.0.339 - PyPI langchain-core: affected < 0.1.30; fixed in 0.1.30 ## Suggested inspection (read-only) - `python -m pip show langchain`: prints the installed version. Run with the environment that serves production active. - `python -m pip show langchain-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langchain, langchain-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h59x-p739-982c (OSV record GHSA-h59x-p739-982c lists affected ranges: PyPI langchain >=0 =0 <0.1.30 (fixed)) - Verified: https://github.com/advisories/GHSA-h59x-p739-982c (GitHub-reviewed advisory GHSA-h59x-p739-982c lists affected ranges: PyPI langchain >=0 =0 <0.1.30) Commands are suggestions: review each one before running it.
Loading voting…