AWS Amplify CLI has incorrect trust policy management
CVE-2024-28056GHSA-846g-p7hm-f54r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@aws-amplify/cli 12.10.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @aws-amplify/cli
- Affected
- < 12.10.1
- Fixed in
- 12.10.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-846g-p7hm-f54r lists affected ranges: npm @aws-amplify/cli >=0 <12.10.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-846g-p7hm-f54r lists affected ranges: npm @aws-amplify/cli >=0 <12.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-28056: 1.67% estimated exploitation activity in the next 30 days; percentile 76.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM roles associated with Amplify projects. When the Authentication component is removed from an Amplify project, a Condition property is removed but "Effect":"Allow" remains present, and consequently sts:AssumeRoleWithWebIdentity would be available to threat actors with no conditions. Thus, if Amplify CLI had been used to remove the Authentication component from a project built between August 2019 and January 2024, an "assume role" may have occurred, and may have been leveraged to obtain unauthorized access to an organization's AWS resources. NOTE: the problem could only occur if an authorized AWS user removed an Authentication component. (The vulnerability did not give a threat actor the ability to remove an Authentication component.) However, in realistic situations, an authorized AWS user may have removed an Authentication component, e.g., if the objective were to stop using built-in Cognito…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-846g-p7hm-f54r
- Revision 1 · created ·
Published from osv record GHSA-846g-p7hm-f54r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28056 Advisory: AWS Amplify CLI has incorrect trust policy management IDs: CVE-2024-28056, GHSA-846g-p7hm-f54r Record: https://patchnext.com/advisories/cve-2024-28056 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @aws-amplify/cli 12.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @aws-amplify/cli: affected < 12.10.1; fixed in 12.10.1 ## Suggested inspection (read-only) - `npm ls @aws-amplify/cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @aws-amplify/cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-846g-p7hm-f54r (OSV record GHSA-846g-p7hm-f54r lists affected ranges: npm @aws-amplify/cli >=0 <12.10.1 (fixed)) - Verified: https://github.com/advisories/GHSA-846g-p7hm-f54r (GitHub-reviewed advisory GHSA-846g-p7hm-f54r lists affected ranges: npm @aws-amplify/cli >=0 <12.10.1) Commands are suggestions: review each one before running it.
Loading voting…