Skip to content

← Actionable
High, CVSS 8.4

*const c_void / ExternalPointer unsoundness leading to use-after-free

CVE-2024-27934GHSA-3j27-563v-28wf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (Deno 1.40.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io Deno

    Affected
    >= 1.36.2, < 1.40.3
    Fixed in
    1.40.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-27934: 0.39% estimated exploitation activity in the next 30 days; percentile 33.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Use of inherently unsafe const cvoid and ExternalPointer leads to use-after-free access of the underlying structure, resulting in arbitrary code execution. Details const cvoid and ExternalPointer (defined via external!() macros) types are used to represent v8::External wrapping arbitrary void with an external lifetime. This is inherently unsafe as we are effectively eliding all Rust lifetime safety guarantees. const cvoid is trivially unsafe. ExternalPointer attempts to resolve this issue by wrapping the underlying pointer with a usized marker (ExternalWithMarker<T). However, the marker relies on the randomness of PIE address (binary base address) which is still trivially exploitable for a non-PIE binary. It is also equally exploitable on a PIE binary when an attacker is able to derandomize the PIE address. This is problematic as it escalates an information leak of the PIE address into an exploitable vulnerability. Note that an attacker able to control code executed inside…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3j27-563v-28wf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27934

Advisory: *const c_void / ExternalPointer unsoundness leading to use-after-free
IDs: CVE-2024-27934, GHSA-3j27-563v-28wf
Record: https://patchnext.com/advisories/cve-2024-27934 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: Deno 1.40.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io Deno: affected >= 1.36.2, < 1.40.3; fixed in 1.40.3

## Suggested inspection (read-only)
- crates.io Deno: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on Deno.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3j27-563v-28wf (GitHub-reviewed advisory GHSA-3j27-563v-28wf lists affected ranges: crates.io Deno >=1.36.2 <1.40.3)

Commands are suggestions: review each one before running it.

Loading voting…