Vantage6: 2FA can be circumvented with hacked email access
CVE-2024-27928GHSA-4c5c-2vc3-x5w2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vantage6 5.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vantage6
- Affected
- < 5.0.0
- Fixed in
- 5.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4c5c-2vc3-x5w2 lists affected ranges: PyPI vantage6 >=0 <5.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4c5c-2vc3-x5w2 lists affected ranges: PyPI vantage6 >=0 <5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-27928: 0.28% estimated exploitation activity in the next 30 days; percentile 20.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If an attacker hacks into a vantage6 user's email account, they can 1) reset the password via email and then 2) reset the 2FA token via email. This way they reduce 2FA to 1FA (email access). Note that most email providers require 2FA to access email, so this issue is not very likely to cause issues.
Proposed solution Many web apps do not provide functionality to reset 2FA token (probably for this reason), but provide recovery codes as well. It would be better to provide these recovery codes to the user 1 time and then delete the option to reset it. An alternative may be to only let server administrators reset 2FA token. However, this has as disadvantage that a hacked email account may send messages to the server admin to reset them, which they may fall for.
Patches No
Workarounds No
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-4c5c-2vc3-x5w2
- Revision 4 · amended ·
Amended from ghsa record GHSA-4c5c-2vc3-x5w2
- Revision 3 · amended ·
Amended from ghsa record GHSA-4c5c-2vc3-x5w2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4c5c-2vc3-x5w2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27928 Advisory: Vantage6: 2FA can be circumvented with hacked email access IDs: CVE-2024-27928, GHSA-4c5c-2vc3-x5w2 Record: https://patchnext.com/advisories/cve-2024-27928 (revision 5, source checked 4 Nov 2026, 06:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vantage6 5.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vantage6: affected < 5.0.0; fixed in 5.0.0 ## Suggested inspection (read-only) - `python -m pip show vantage6`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vantage6. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4c5c-2vc3-x5w2 (OSV record GHSA-4c5c-2vc3-x5w2 lists affected ranges: PyPI vantage6 >=0 <5.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4c5c-2vc3-x5w2 (GitHub-reviewed advisory GHSA-4c5c-2vc3-x5w2 lists affected ranges: PyPI vantage6 >=0 <5.0.0) Commands are suggestions: review each one before running it.
Loading voting…