Skip to content

← Actionable
Medium, CVSS 6.5amended

RSSHub vulnerable to Server-Side Request Forgery

CVE-2024-27927GHSA-3p3p-cgj7-vgw3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rsshub 1.0.0-master.a429472), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm rsshub

    Affected
    < 1.0.0-master.a429472
    Fixed in
    1.0.0-master.a429472

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
EPSS
  • CVE-2024-27927: 1.04% estimated exploitation activity in the next 30 days; percentile 64.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Serveral Server-Side Request Forgery (SSRF) vulnerabilities in RSSHub allow remote attackers to use the server as a proxy to send HTTP GET requests to arbitrary targets and retrieve information in the internal network or conduct Denial-of-Service (DoS) attacks. Details /mastodon/acct/:acct/statuses/:onlymedia? https://github.com/DIYgod/RSSHub/blob/5928c5db2472e101c2f5c3bafed77a2f72edd40a/lib/routes/mastodon/acct.js#L4-L7 https://github.com/DIYgod/RSSHub/blob/5928c5db2472e101c2f5c3bafed77a2f72edd40a/lib/routes/mastodon/utils.js#L85-L105 /zjol/paper/:id? https://github.com/DIYgod/RSSHub/blob/172f6cfd2b69ea6affdbdedf61e6dde1671f3796/lib/routes/zjol/paper.js#L7-L13 /m4/:id?/:category https://github.com/DIYgod/RSSHub/blob/172f6cfd2b69ea6affdbdedf61e6dde1671f3796/lib/routes/m4/index.js#L10-L14 PoC - https://rsshub.app/mastodon/acct/test@a6wt15r2.requestrepo.com%23/statuses - https://rsshub.app/zjol/paper/a6wt15r2.requestrepo.com%23 -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3p3p-cgj7-vgw3

  2. Revision 1 · created ·

    Published from osv record GHSA-3p3p-cgj7-vgw3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27927

Advisory: RSSHub vulnerable to Server-Side Request Forgery
IDs: CVE-2024-27927, GHSA-3p3p-cgj7-vgw3
Record: https://patchnext.com/advisories/cve-2024-27927 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rsshub 1.0.0-master.a429472. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm rsshub: affected < 1.0.0-master.a429472; fixed in 1.0.0-master.a429472

## Suggested inspection (read-only)
- `npm ls rsshub --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rsshub.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3p3p-cgj7-vgw3 (OSV record GHSA-3p3p-cgj7-vgw3 lists affected ranges: npm rsshub >=0 <1.0.0-master.a429472 (fixed))
- Verified: https://github.com/advisories/GHSA-3p3p-cgj7-vgw3 (GitHub-reviewed advisory GHSA-3p3p-cgj7-vgw3 lists affected ranges: npm rsshub >=0 <1.0.0-master.a429472)

Commands are suggestions: review each one before running it.

Loading voting…