Skip to content

← Actionable
Medium, CVSS 6.1amended

RSSHub Cross-site Scripting vulnerability caused by internal media proxy

CVE-2024-27926GHSA-2wqw-hr4f-xrhh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rsshub 1.0.0-master.d8ca915), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm rsshub

    Affected
    >= 1.0.0-master.cbbd829, < 1.0.0-master.d8ca915
    Fixed in
    1.0.0-master.d8ca915

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-27926: 0.52% estimated exploitation activity in the next 30 days; percentile 44.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When the specially crafted image is supplied to the internal media proxy, it proxies the image without handling XSS vulnerabilities, allowing for the execution of arbitrary JavaScript code. Users who access the deliberately constructed URL are affected. Patches This vulnerability was fixed in version https://github.com/DIYgod/RSSHub/commit/4d3e5d79c1c17837e931b4cd253d2013b487aa87. Please upgrade to this or a later version. Workarounds No.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2wqw-hr4f-xrhh

  2. Revision 1 · created ·

    Published from osv record GHSA-2wqw-hr4f-xrhh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27926

Advisory: RSSHub Cross-site Scripting vulnerability caused by internal media proxy
IDs: CVE-2024-27926, GHSA-2wqw-hr4f-xrhh
Record: https://patchnext.com/advisories/cve-2024-27926 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rsshub 1.0.0-master.d8ca915. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm rsshub: affected >= 1.0.0-master.cbbd829, < 1.0.0-master.d8ca915; fixed in 1.0.0-master.d8ca915

## Suggested inspection (read-only)
- `npm ls rsshub --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rsshub.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2wqw-hr4f-xrhh (OSV record GHSA-2wqw-hr4f-xrhh lists affected ranges: npm rsshub >=1.0.0-master.cbbd829 <1.0.0-master.d8ca915 (fixed))
- Verified: https://github.com/advisories/GHSA-2wqw-hr4f-xrhh (GitHub-reviewed advisory GHSA-2wqw-hr4f-xrhh lists affected ranges: npm rsshub >=1.0.0-master.cbbd829 <1.0.0-master.d8ca915)

Commands are suggestions: review each one before running it.

Loading voting…