Skip to content

← Actionable
Critical, CVSS 9.8amended

HTTP Handling Vulnerability in the Bare server

CVE-2024-27922GHSA-86fc-f9gr-v533

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@tomphttp/bare-server-node 2.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-27922: 0.82% estimated exploitation activity in the next 30 days; percentile 57.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability relates to insecure handling of HTTP requests by the @tomphttp/bare-server-node package. This flaw potentially exposes the users of the package to manipulation of their web traffic. The impact may vary depending on the specific usage of the package but it can potentially affect any system where this package is in use. Patches Yes, the problem has been patched. We advise all users to upgrade to version @tomphttp/bare-server-node@2.0.2 as soon as possible. Workarounds Given the nature of the vulnerability, the most effective solution is to upgrade to the patched version of the package. Specific workaround strategies will be disclosed later due to security considerations. References Further information about this vulnerability will be provided at a later date to provide users with an opportunity to upgrade to a patched version and to prevent potential exploitation of the vulnerability. Users are advised to follow the repository announcements and updates.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-86fc-f9gr-v533

  2. Revision 1 · created ·

    Published from osv record GHSA-86fc-f9gr-v533

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27922

Advisory: HTTP Handling Vulnerability in the Bare server
IDs: CVE-2024-27922, GHSA-86fc-f9gr-v533
Record: https://patchnext.com/advisories/cve-2024-27922 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @tomphttp/bare-server-node 2.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @tomphttp/bare-server-node: affected < 2.0.2; fixed in 2.0.2

## Suggested inspection (read-only)
- `npm ls @tomphttp/bare-server-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @tomphttp/bare-server-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-86fc-f9gr-v533 (OSV record GHSA-86fc-f9gr-v533 lists affected ranges: npm @tomphttp/bare-server-node >=0 <2.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-86fc-f9gr-v533 (GitHub-reviewed advisory GHSA-86fc-f9gr-v533 lists affected ranges: npm @tomphttp/bare-server-node >=0 <2.0.2)

Commands are suggestions: review each one before running it.

Loading voting…