Apache Airflow: DAG Code and Import Error Permissions Ignored
CVE-2024-27906GHSA-6v6w-h8m6-7mv2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 2.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- <= 2.8.1
- Fixed in
- 2.8.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6v6w-h8m6-7mv2 lists affected ranges: PyPI apache-airflow >=0 <2.8.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6v6w-h8m6-7mv2 lists affected ranges: PyPI apache-airflow >=0 <=2.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-27906: 0.34% estimated exploitation activity in the next 30 days; percentile 28.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI. Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6v6w-h8m6-7mv2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6v6w-h8m6-7mv2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27906 Advisory: Apache Airflow: DAG Code and Import Error Permissions Ignored IDs: CVE-2024-27906, GHSA-6v6w-h8m6-7mv2 Record: https://patchnext.com/advisories/cve-2024-27906 (revision 3, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 2.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected <= 2.8.1; fixed in 2.8.2 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6v6w-h8m6-7mv2 (OSV record GHSA-6v6w-h8m6-7mv2 lists affected ranges: PyPI apache-airflow >=0 <2.8.2 (fixed)) - Verified: https://github.com/advisories/GHSA-6v6w-h8m6-7mv2 (GitHub-reviewed advisory GHSA-6v6w-h8m6-7mv2 lists affected ranges: PyPI apache-airflow >=0 <=2.8.1) Commands are suggestions: review each one before running it.
Loading voting…