Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying
CVE-2024-27894GHSA-c2x9-vw5h-39vc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.pulsar:pulsar-functions-worker 3.2.1, 3.1.3, 3.0.3, 2.11.4, 2.10.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.pulsar:pulsar-functions-worker
- Affected
- >= 2.4.0, < 2.10.6>= 2.11.0, < 2.11.4>= 3.0.0, < 3.0.3>= 3.1.0, < 3.1.3>= 3.2.0, < 3.2.1
- Fixed in
- 3.2.1, 2.11.4, 3.1.3, 3.0.3, 2.10.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c2x9-vw5h-39vc lists affected ranges: Maven org.apache.pulsar:pulsar-functions-worker >=2.4.0 =2.11.0 =3.0.0 =3.1.0 =3.2.0 <3.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-27894: 1.90% estimated exploitation activity in the next 30 days; percentile 79.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Pulsar Functions Worker includes a capability that permits authenticated users to create functions where the function's implementation is referenced by a URL. The supported URL schemes include "file", "http", and "https". When a function is created using this method, the Functions Worker will retrieve the implementation from the URL provided by the user. However, this feature introduces a vulnerability that can be exploited by an attacker to gain unauthorized access to any file that the Pulsar Functions Worker process has permissions to read. This includes reading the process environment which potentially includes sensitive information, such as secrets. Furthermore, an attacker could leverage this vulnerability to use the Pulsar Functions Worker as a proxy to access the content of remote HTTP and HTTPS endpoint URLs. This could also be used to carry out denial of service attacks. This vulnerability also applies to the Pulsar Broker when it is configured with…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c2x9-vw5h-39vc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27894 Advisory: Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying IDs: CVE-2024-27894, GHSA-c2x9-vw5h-39vc Record: https://patchnext.com/advisories/cve-2024-27894 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.pulsar:pulsar-functions-worker 3.2.1, 3.1.3, 3.0.3, 2.11.4, 2.10.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.pulsar:pulsar-functions-worker: affected >= 2.4.0, < 2.10.6; >= 2.11.0, < 2.11.4; >= 3.0.0, < 3.0.3; >= 3.1.0, < 3.1.3; >= 3.2.0, < 3.2.1; fixed in 3.2.1, 2.11.4, 3.1.3, 3.0.3, 2.10.6 ## Suggested inspection (read-only) - Maven org.apache.pulsar:pulsar-functions-worker: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.pulsar:pulsar-functions-worker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c2x9-vw5h-39vc (GitHub-reviewed advisory GHSA-c2x9-vw5h-39vc lists affected ranges: Maven org.apache.pulsar:pulsar-functions-worker >=2.4.0 =2.11.0 =3.0.0 =3.1.0 =3.2.0 <3.2.1) Commands are suggestions: review each one before running it.
Loading voting…