RPyC's missing security check results in code execution when using numpy.array on the server-side.
CVE-2024-27758GHSA-h5cg-53g7-gqjw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rpyc 6.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI rpyc
- Affected
- >= 4.0.0, < 6.0.0
- Fixed in
- 6.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h5cg-53g7-gqjw lists affected ranges: PyPI rpyc >=4.0.0 <6.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h5cg-53g7-gqjw lists affected ranges: PyPI rpyc >=4.0.0 <6.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N · score source
- EPSS
- CVE-2024-27758: 0.51% estimated exploitation activity in the next 30 days; percentile 43.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue in Open Source: RPyC v.4.00 thru v.5.3.1 allows a remote attacker to execute arbitrary code via a crafted script to the array attribute component. This vulnerability was introduced in 9f45f826. Attack Vector RPyC services that rely on the array attribute used by numpy are impacted. When the server-side exposes a method that calls the attribute named array for a a client provided netref (e.g., np.array(clientnetref)), a remote attacker can craft a class which results in remote code execution Impact Assuming the system exposes a method that calls the attribute array, an attacker can execute code using the vulnerable component. Patches The fix is available in RPyC 6.0.0. The major version change is because some users may need to set allowpickle to True when migrating to RPyC 6. Workarounds While the recommend fix is to upgrade to RPyC 6.0.0, the workaround is to apply bba1d356 as patch. Affected Component The affected component is the array method constructed for NetrefClass.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h5cg-53g7-gqjw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h5cg-53g7-gqjw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27758 Advisory: RPyC's missing security check results in code execution when using numpy.array on the server-side. IDs: CVE-2024-27758, GHSA-h5cg-53g7-gqjw Record: https://patchnext.com/advisories/cve-2024-27758 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rpyc 6.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI rpyc: affected >= 4.0.0, < 6.0.0; fixed in 6.0.0 ## Suggested inspection (read-only) - `python -m pip show rpyc`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rpyc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h5cg-53g7-gqjw (OSV record GHSA-h5cg-53g7-gqjw lists affected ranges: PyPI rpyc >=4.0.0 <6.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-h5cg-53g7-gqjw (GitHub-reviewed advisory GHSA-h5cg-53g7-gqjw lists affected ranges: PyPI rpyc >=4.0.0 <6.0.0) Commands are suggestions: review each one before running it.
Loading voting…