Bagist Cross-site Scripting vulnerability
CVE-2024-27499GHSA-w5mx-334j-6fwv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bagisto/bagisto 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist bagisto/bagisto
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w5mx-334j-6fwv lists affected ranges: Packagist bagisto/bagisto >=0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L · score source
- EPSS
- CVE-2024-27499: 0.52% estimated exploitation activity in the next 30 days; percentile 44.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Bagisto is vulnerable to cross-site scripting (XSS) via png file upload vulnerability in product review option.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w5mx-334j-6fwv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27499 Advisory: Bagist Cross-site Scripting vulnerability IDs: CVE-2024-27499, GHSA-w5mx-334j-6fwv Record: https://patchnext.com/advisories/cve-2024-27499 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bagisto/bagisto 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist bagisto/bagisto: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Packagist bagisto/bagisto: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bagisto/bagisto. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w5mx-334j-6fwv (GitHub-reviewed advisory GHSA-w5mx-334j-6fwv lists affected ranges: Packagist bagisto/bagisto >=0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…