Skip to content

← Actionable
Unrated

Rack CORS Middleware has Insecure File Permissions

CVE-2024-27456GHSA-785g-282q-pwvx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack-cors 2.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rack-cors

    Affected
    >= 2.0.1, <= 2.0.1
    Fixed in
    2.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2024-27456: 0.77% estimated exploitation activity in the next 30 days; percentile 55.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

rack-cors (aka Rack CORS Middleware) 2.0.1 has 0666 permissions for the .rb files.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-785g-282q-pwvx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27456

Advisory: Rack CORS Middleware has Insecure File Permissions
IDs: CVE-2024-27456, GHSA-785g-282q-pwvx
Record: https://patchnext.com/advisories/cve-2024-27456 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rack-cors 2.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rack-cors: affected >= 2.0.1, <= 2.0.1; fixed in 2.0.2

## Suggested inspection (read-only)
- RubyGems rack-cors: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rack-cors.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-785g-282q-pwvx (GitHub-reviewed advisory GHSA-785g-282q-pwvx lists affected ranges: RubyGems rack-cors >=2.0.1 <=2.0.1)

Commands are suggestions: review each one before running it.

Loading voting…