pretix mishandles file validation
CVE-2024-27447GHSA-672r-97r7-vx2q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pretix 2024.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pretix
- Affected
- < 2024.1.1
- Fixed in
- 2024.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-672r-97r7-vx2q lists affected ranges: PyPI pretix >=0 <2024.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-672r-97r7-vx2q lists affected ranges: PyPI pretix >=0 <2024.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2024-27447: 0.82% estimated exploitation activity in the next 30 days; percentile 57.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
pretix before 2024.1.1 mishandles file validation.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-672r-97r7-vx2q
- Revision 1 · created ·
Published from osv record GHSA-672r-97r7-vx2q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27447 Advisory: pretix mishandles file validation IDs: CVE-2024-27447, GHSA-672r-97r7-vx2q Record: https://patchnext.com/advisories/cve-2024-27447 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pretix 2024.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pretix: affected < 2024.1.1; fixed in 2024.1.1 ## Suggested inspection (read-only) - `python -m pip show pretix`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pretix. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-672r-97r7-vx2q (OSV record GHSA-672r-97r7-vx2q lists affected ranges: PyPI pretix >=0 <2024.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-672r-97r7-vx2q (GitHub-reviewed advisory GHSA-672r-97r7-vx2q lists affected ranges: PyPI pretix >=0 <2024.1.1) Commands are suggestions: review each one before running it.
Loading voting…