Skip to content

← Actionable
High, CVSS 7.5

phpseclib guardrails needed on OID length

CVE-2024-27355GHSA-f2qx-66wf-wvvx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpseclib/phpseclib 3.0.36, 2.0.47, 1.0.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpseclib/phpseclib

    Affected
    >= 2.0.0, <= 2.0.46>= 3.0.0, <= 3.0.35>= 0.1.1, <= 1.0.22
    Fixed in
    2.0.47, 1.0.23, 3.0.36

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-27355: 0.57% estimated exploitation activity in the next 30 days; percentile 47.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any application using that loads untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). Patches https://github.com/phpseclib/phpseclib/commit/e32531001b4d62c66c3d824ccef54ffad835eb59 Workarounds No. Resources https://github.com/phpseclib/phpseclib/commit/e32531001b4d62c66c3d824ccef54ffad835eb59 https://www.usenix.org/system/files/conference/usenixsecurity25/sec25cycle1-prepub-599-shi-bing.pdf

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f2qx-66wf-wvvx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27355

Advisory: phpseclib guardrails needed on OID length
IDs: CVE-2024-27355, GHSA-f2qx-66wf-wvvx
Record: https://patchnext.com/advisories/cve-2024-27355 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpseclib/phpseclib 3.0.36, 2.0.47, 1.0.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpseclib/phpseclib: affected >= 2.0.0, <= 2.0.46; >= 3.0.0, <= 3.0.35; >= 0.1.1, <= 1.0.22; fixed in 2.0.47, 1.0.23, 3.0.36

## Suggested inspection (read-only)
- Packagist phpseclib/phpseclib: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpseclib/phpseclib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f2qx-66wf-wvvx (GitHub-reviewed advisory GHSA-f2qx-66wf-wvvx lists affected ranges: Packagist phpseclib/phpseclib >=2.0.0 =3.0.0 =0.1.1 <=1.0.22)

Commands are suggestions: review each one before running it.

Loading voting…