Skip to content

← Actionable
Critical, CVSS 9.3Exploited · CISA KEV

Apache HugeGraph-Server: Command execution in gremlin

CVE-2024-27348GHSA-29rc-vq7f-x335

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.hugegraph:hugegraph-core 1.3.0; org.apache.hugegraph:hugegraph-api 1.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A · score source
EPSS
  • CVE-2024-27348: 99.21% estimated exploitation activity in the next 30 days; percentile 99.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

RCE-Remote Command Execution vulnerability in Apache HugeGraph-Server.This issue affects Apache HugeGraph-Server: from 1.0.0 before 1.3.0 in Java8 & Java11 Users are recommended to upgrade to version 1.3.0 with Java11 & enable the Auth system, which fixes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-29rc-vq7f-x335

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27348

Advisory: Apache HugeGraph-Server: Command execution in gremlin
IDs: CVE-2024-27348, GHSA-29rc-vq7f-x335
Record: https://patchnext.com/advisories/cve-2024-27348 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.apache.hugegraph:hugegraph-core 1.3.0; org.apache.hugegraph:hugegraph-api 1.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.hugegraph:hugegraph-core: affected >= 1.0.0, < 1.3.0; fixed in 1.3.0
- Maven org.apache.hugegraph:hugegraph-api: affected >= 1.0.0, < 1.3.0; fixed in 1.3.0

## Suggested inspection (read-only)
- Maven org.apache.hugegraph:hugegraph-core: check the installed version with your package manager.
- Maven org.apache.hugegraph:hugegraph-api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.hugegraph:hugegraph-core, org.apache.hugegraph:hugegraph-api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-29rc-vq7f-x335 (GitHub-reviewed advisory GHSA-29rc-vq7f-x335 lists affected ranges: Maven org.apache.hugegraph:hugegraph-api >=1.0.0 =1.0.0 <1.3.0)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2024-27348 to the Known Exploited Vulnerabilities catalog on 2024-09-18.)

Commands are suggestions: review each one before running it.

Loading voting…