aiosmtpd vulnerable to SMTP smuggling
CVE-2024-27305GHSA-pr2m-px7j-xg65
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aiosmtpd 1.4.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI aiosmtpd
- Affected
- < 1.4.5
- Fixed in
- 1.4.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pr2m-px7j-xg65 lists affected ranges: PyPI aiosmtpd >=0 <1.4.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pr2m-px7j-xg65 lists affected ranges: PyPI aiosmtpd >=0 <1.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2024-27305: 0.37% estimated exploitation activity in the next 30 days; percentile 31.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary aiosmtpd is vulnerable to inbound SMTP smuggling. SMTP smuggling is a novel vulnerability based on not so novel interpretation differences of the SMTP protocol. By exploiting SMTP smuggling, an attacker may send smuggle/spoof e-mails with fake sender addresses, allowing advanced phishing attacks. This issue also existed in other SMTP software like Postfix (https://www.postfix.org/smtp-smuggling.html). Details Detailed information on SMTP smuggling can be found in the full blog post (https://sec-consult.com/blog/detail/smtp-smuggling-spoofing-e-mails-worldwide/) or on the Postfix homepage (https://www.postfix.org/smtp-smuggling.html). (and soon on the official website https://smtpsmuggling.com/) Impact With the right SMTP server constellation, an attacker can send spoofed e-mails to inbound/receiving aiosmtpd instances.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pr2m-px7j-xg65
- Revision 1 · created ·
Published from osv record GHSA-pr2m-px7j-xg65
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27305 Advisory: aiosmtpd vulnerable to SMTP smuggling IDs: CVE-2024-27305, GHSA-pr2m-px7j-xg65 Record: https://patchnext.com/advisories/cve-2024-27305 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aiosmtpd 1.4.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI aiosmtpd: affected < 1.4.5; fixed in 1.4.5 ## Suggested inspection (read-only) - `python -m pip show aiosmtpd`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aiosmtpd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pr2m-px7j-xg65 (OSV record GHSA-pr2m-px7j-xg65 lists affected ranges: PyPI aiosmtpd >=0 <1.4.5 (fixed)) - Verified: https://github.com/advisories/GHSA-pr2m-px7j-xg65 (GitHub-reviewed advisory GHSA-pr2m-px7j-xg65 lists affected ranges: PyPI aiosmtpd >=0 <1.4.5) Commands are suggestions: review each one before running it.
Loading voting…