phpMyFAQ stored Cross-site Scripting at user email
CVE-2024-27300GHSA-q7g6-xfh2-vhpx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 3.2.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyfaq/phpmyfaq
- Affected
- >= 3.2.5, <= 3.2.5
- Fixed in
- 3.2.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q7g6-xfh2-vhpx lists affected ranges: Packagist phpmyfaq/phpmyfaq >=3.2.5 <=3.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2024-27300: 0.69% estimated exploitation activity in the next 30 days; percentile 52.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The email field in phpMyFAQ's user control panel page is vulnerable to stored XSS attacks due to the inadequacy of PHP's FILTERVALIDATEEMAIL function, which only validates the email format, not its content. This vulnerability enables an attacker to execute arbitrary client-side JavaScript within the context of another user's phpMyFAQ session. Details Despite using PHP's FILTERVALIDATEEMAIL function, the email field does not adequately validate the content of the email address. This means that malicious input, such as JavaScript code, can be accepted and stored in the database without being detected. When the stored data is retrieved and displayed on web pages, it is not properly sanitized to remove or neutralize any potentially harmful content, such as JavaScript code which leads to Stored XSS. PoC 1. Login as any user, go to the user control panel, change email to any valid email and intercept the request. 2. Modify the request’s email parameter to the following payload:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q7g6-xfh2-vhpx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27300 Advisory: phpMyFAQ stored Cross-site Scripting at user email IDs: CVE-2024-27300, GHSA-q7g6-xfh2-vhpx Record: https://patchnext.com/advisories/cve-2024-27300 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 3.2.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyfaq/phpmyfaq: affected >= 3.2.5, <= 3.2.5; fixed in 3.2.6 ## Suggested inspection (read-only) - Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyfaq/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q7g6-xfh2-vhpx (GitHub-reviewed advisory GHSA-q7g6-xfh2-vhpx lists affected ranges: Packagist phpmyfaq/phpmyfaq >=3.2.5 <=3.2.5) Commands are suggestions: review each one before running it.
Loading voting…