Skip to content

← Actionable
High, CVSS 8.2amended

Directus has MySQL accent insensitive email matching

CVE-2024-27295GHSA-qw9g-7549-7wg5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 10.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    <= 10.8.2
    Fixed in
    10.8.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2024-27295: 0.70% estimated exploitation activity in the next 30 days; percentile 53.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Password reset vulnerable to accent confusion The password reset mechanism of the Directus backend is implemented in a way where combined with (specific, need to double check if i can work around) configuration in MySQL or MariaDB. As such, it allows attackers to receive a password reset email of a victim user, specifically having it arrive at a similar email address as the victim with a one or more characters changed to use accents. This is due to the fact that by default MySQL/MariaDB are configured for accent-insenstive and case-insensitve comparisons. MySQL weak comparison: This is exploitable due to an error in the API using the supplied email address for sending the reset password mail instead of using the email from the database. Steps to reproduce: 1. If the attacker knows the email address of the victim user, i.e., julian@cure53.de. (possibly just the domain could be enough for an educated guess) 2. A off-by-one accented domain cüre53.de can be registered to be able to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qw9g-7549-7wg5

  2. Revision 1 · created ·

    Published from osv record GHSA-qw9g-7549-7wg5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27295

Advisory: Directus has MySQL accent insensitive email matching
IDs: CVE-2024-27295, GHSA-qw9g-7549-7wg5
Record: https://patchnext.com/advisories/cve-2024-27295 (revision 2, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 10.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected <= 10.8.2; fixed in 10.8.3

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qw9g-7549-7wg5 (OSV record GHSA-qw9g-7549-7wg5 lists affected ranges: npm directus >=0 <10.8.3 (fixed))
- Verified: https://github.com/advisories/GHSA-qw9g-7549-7wg5 (GitHub-reviewed advisory GHSA-qw9g-7549-7wg5 lists affected ranges: npm directus >=0 <=10.8.2)

Commands are suggestions: review each one before running it.

Loading voting…