Docassemble HTML and javascript injection
CVE-2024-27290GHSA-pcfx-g2j2-f6f6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (docassemble-webapp 1.4.97), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI docassemble-webapp
- Affected
- < 1.4.97
- Fixed in
- 1.4.97
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pcfx-g2j2-f6f6 lists affected ranges: PyPI docassemble-webapp >=0 <1.4.97 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pcfx-g2j2-f6f6 lists affected ranges: PyPI docassemble-webapp >=0 <1.4.97
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-27290: 0.43% estimated exploitation activity in the next 30 days; percentile 37.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A user could type HTML into a field, including the field for the user's name, and then that HTML could be displayed on the screen as HTML. The HTML can also contain <script tags allowing JavaScript to execute on the page. Patches The vulnerability has been patched in version 1.4.97 of the master branch. The Docker image on docker.io has been patched. Workarounds If upgrading is not possible, manually apply the changes of 4801ac7 and restart the server (e.g., by pressing Save on the Configuration screen). Credit The vulnerability was discovered by Riyush Ghimire (@richighimi). For more information If you have any questions or comments about this advisory: Open an issue in docassemble Join the Slack channel Email us at jhpyle@gmail.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pcfx-g2j2-f6f6
- Revision 1 · created ·
Published from osv record GHSA-pcfx-g2j2-f6f6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27290 Advisory: Docassemble HTML and javascript injection IDs: CVE-2024-27290, GHSA-pcfx-g2j2-f6f6 Record: https://patchnext.com/advisories/cve-2024-27290 (revision 2, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: docassemble-webapp 1.4.97. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI docassemble-webapp: affected < 1.4.97; fixed in 1.4.97 ## Suggested inspection (read-only) - `python -m pip show docassemble-webapp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on docassemble-webapp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pcfx-g2j2-f6f6 (OSV record GHSA-pcfx-g2j2-f6f6 lists affected ranges: PyPI docassemble-webapp >=0 <1.4.97 (fixed)) - Verified: https://github.com/advisories/GHSA-pcfx-g2j2-f6f6 (GitHub-reviewed advisory GHSA-pcfx-g2j2-f6f6 lists affected ranges: PyPI docassemble-webapp >=0 <1.4.97) Commands are suggestions: review each one before running it.
Loading voting…