1Panel open source panel project has an unauthorized vulnerability.
CVE-2024-27288GHSA-26w3-q4j8-4xjp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/1Panel-dev/1Panel 1.10.1-lts), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/1Panel-dev/1Panel
- Affected
- <= 1.10.0-lts
- Fixed in
- 1.10.1-lts
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-26w3-q4j8-4xjp lists affected ranges: Go github.com/1Panel-dev/1Panel >=0 <=1.10.0-lts
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2024-27288: 0.47% estimated exploitation activity in the next 30 days; percentile 40.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The steps are as follows: 1. Access https://IP:PORT/ in the browser, which prompts the user to access with a secure entry point. 2. Use Burp to intercept: When opening the browser and entering the URL (allowing the first intercepted packet through Burp), the following is displayed: It is found that in this situation, we can access the console page (although no data is returned and no modification operations can be performed)." Affected versions: <= 1.10.0-lts Patches The vulnerability has been fixed in v1.10.1-lts. Workarounds It is recommended to upgrade the version to 1.10.1-lts. References If you have any questions or comments about this advisory: Open an issue in https://github.com/1Panel-dev/1Panel Email us at wanghe@fit2cloud.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-26w3-q4j8-4xjp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27288 Advisory: 1Panel open source panel project has an unauthorized vulnerability. IDs: CVE-2024-27288, GHSA-26w3-q4j8-4xjp Record: https://patchnext.com/advisories/cve-2024-27288 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/1Panel-dev/1Panel 1.10.1-lts. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/1Panel-dev/1Panel: affected <= 1.10.0-lts; fixed in 1.10.1-lts ## Suggested inspection (read-only) - Go github.com/1Panel-dev/1Panel: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/1Panel-dev/1Panel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-26w3-q4j8-4xjp (GitHub-reviewed advisory GHSA-26w3-q4j8-4xjp lists affected ranges: Go github.com/1Panel-dev/1Panel >=0 <=1.10.0-lts) Commands are suggestions: review each one before running it.
Loading voting…