Skip to content

← Actionable
Medium, CVSS 6.5amended

esphome vulnerable to stored Cross-site Scripting in edit configuration file API

CVE-2024-27287GHSA-9p43-hj5j-96h5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (esphome 2024.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI esphome

    Affected
    >= 2023.12.9, < 2024.2.2
    Fixed in
    2024.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2024-27287: 0.68% estimated exploitation activity in the next 30 days; percentile 52.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Edit configuration file API in dashboard component of ESPHome version 2023.12.9 (command line installation and Home Assistant add-on) serves unsanitized data with “Content-Type: text/html; charset=UTF-8”, allowing remote authenticated user to inject arbitrary web script and exfiltrate session cookies via Cross-Site scripting (XSS). Credits Spike Reply Cybersecurity Teams Details It is possible for a malicious authenticated user to inject arbitrary Javascript in configuration files using a POST request to the /edit endpoint, the configuration parameter allows to specify the file to write. To trigger the XSS vulnerability, the victim must visit the page /edit?configuration=[xss file]. PoC To reproduce the issue, it is possible to perform a POST request to inject the payload: request: POST /edit?configuration=xss.yaml HTTP/1.1 Host: localhost:6052 User-Agent: Mozilla/5.0 (X11; Linux x8664; rv:109.0) Gecko/20100101 Firefox/116.0 Accept: / Accept-Language: en-US,en;q=0.5…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9p43-hj5j-96h5

  2. Revision 1 · created ·

    Published from osv record GHSA-9p43-hj5j-96h5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-27287

Advisory: esphome vulnerable to stored Cross-site Scripting in edit configuration file API
IDs: CVE-2024-27287, GHSA-9p43-hj5j-96h5
Record: https://patchnext.com/advisories/cve-2024-27287 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: esphome 2024.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI esphome: affected >= 2023.12.9, < 2024.2.2; fixed in 2024.2.2

## Suggested inspection (read-only)
- `python -m pip show esphome`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on esphome.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9p43-hj5j-96h5 (OSV record GHSA-9p43-hj5j-96h5 lists affected ranges: PyPI esphome >=2023.12.9 <2024.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-9p43-hj5j-96h5 (GitHub-reviewed advisory GHSA-9p43-hj5j-96h5 lists affected ranges: PyPI esphome >=2023.12.9 <2024.2.2)

Commands are suggestions: review each one before running it.

Loading voting…