cassandra-rs's non-idiomatic use of iterators leads to use after free
CVE-2024-27284GHSA-x9xc-63hg-vcfq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cassandra-cpp 3.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io cassandra-cpp
- Affected
- < 3.0.0
- Fixed in
- 3.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x9xc-63hg-vcfq lists affected ranges: crates.io cassandra-cpp >=0 <3.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-27284: 0.82% estimated exploitation activity in the next 30 days; percentile 57.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Code that attempts to use an item (e.g., a row) returned by an iterator after the iterator has advanced to the next item will be accessing freed memory and experience undefined behaviour. Code that uses the item and then advances the iterator is unaffected. This problem has always existed. This is a use-after-free bug, so it's rated high severity. If your code uses a pre-3.0.0 version of cassandra-rs, and uses an item returned by a cassandra-rs iterator after calling next() on that iterator, then it is vulnerable. However, such code will almost always fail immediately - so we believe it is unlikely that any code using this pattern would have reached production. For peace of mind, we recommend you upgrade anyway. Patches The problem has been fixed in version 3.0.0. Users should upgrade to ensure their code cannot use the problematic pattern. Workarounds Ensure all usage fits the expected pattern. For example, use getfirstrow() rather than an iterator, or completely process an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x9xc-63hg-vcfq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27284 Advisory: cassandra-rs's non-idiomatic use of iterators leads to use after free IDs: CVE-2024-27284, GHSA-x9xc-63hg-vcfq Record: https://patchnext.com/advisories/cve-2024-27284 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cassandra-cpp 3.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io cassandra-cpp: affected < 3.0.0; fixed in 3.0.0 ## Suggested inspection (read-only) - crates.io cassandra-cpp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cassandra-cpp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x9xc-63hg-vcfq (GitHub-reviewed advisory GHSA-x9xc-63hg-vcfq lists affected ranges: crates.io cassandra-cpp >=0 <3.0.0) Commands are suggestions: review each one before running it.
Loading voting…